Soul Calibur III: Definitive Edition for PS2 [RELEASE v1.20 - February 2023]

Hello....question, has the memory card corruption bug been fixed with this mod? I am playing it via OPL on my ps2 but have not made a save file as yet.
 
Is there a way to replace Assassin's model in SC2 with Hwang's SC3 one while keeping Assassins move set?
 
If Inferno doesn’t meant to be playable, then why does he have an alternate costume?

Plus, I wished for Inferno to be playable in this mod of SC3AE.
 

Attachments

  • 4F79C7AB-53BB-4251-8BCA-91E81537AFED.jpeg
    4F79C7AB-53BB-4251-8BCA-91E81537AFED.jpeg
    2.5 MB · Views: 358
  • 49CD5744-0835-4498-8ED3-249DA96E413B.jpeg
    49CD5744-0835-4498-8ED3-249DA96E413B.jpeg
    2.3 MB · Views: 375
  • 4F15FB2C-EFC1-49F0-BAC1-3DEB4F5F36D6.jpeg
    4F15FB2C-EFC1-49F0-BAC1-3DEB4F5F36D6.jpeg
    2.9 MB · Views: 368
Any progression updates? I'm REALLY waiting for the day we could use Amy's/Li-Long's/Hwang's AE movesets!
 
You know that Jaxel himself, the founder of this site, approved this mod's existence, yes?
Get out of here, revamp. No one wants you here.
 
SoulCalibur3 was such a classic game, that has marked the introduction of "Create a Soul" mode.
That marks the time the SoulCalibur world became more immersive for me, as I enjoyed
being able to interact with canon characters with my self insert character. Or well...as close to
one as I could. XD Ah the memories. XD
 
changed my mind
less than 3GB though
includes changelog
Not sure if anyone else has this problem, but PCSX2 will NOT save or load any saves (both NTSC and Japanese) for this mod. Even the provided memory card files don't load. PCSX2 recognizes the game as the Japanese release but all the text is in English, so idk if it's a region problem or intentional.

Cheats don't work either.
 
Last edited:
Is this still being worked on? I know there are people in SC netplay servers worried that you seemingly disappeared without a trace.
 
Hi, i have just downloaded the latest version, 1.20.
I installed it on my ps2, but when i enter into the Museum --> Art gallery, the screen is black and i can only hear the sound.
It is possible to move the cursor but i can't see it, i can only hear its sound effect. It seems that there is an issue.
All the others games mode perfectly work.

I tried it on the PCSX2 emulator and it correctly work so the issue is present in the original hardware only

Did you notice it? thanks!

EDIT: i solved the issue activating MODE 1 = ON on OPL.

Will it be released a new updated version of this great game?
 
Last edited:
i forgot here's a video of the actual Arcade Edition mod
the only one that ever fixed the problems such as variable cancel and updates the move sets to their final state
Ivy and Yoshimitsu are also supported
 
Back